帝国cms不支持数据库名称中带有 - 连字符 切记

👁 2 次浏览 🕔 2026-07-27 19:45:58

正文内容

帝国cms数据库名为rs-c-1 然后帝国cms后台 点击 系统---备份与回复数据--备份数据 然后页面闪了一下就显示空白了 4fQ青帆网络
最后发现原因是数据库名称带有 - 连字符造成的4fQ青帆网络
问题最后确认了,不是配置错、不是连接失败、也不是 display_errors 的问题——是数据库名里的连字符 - 触发了帝国 CMS 的静默 exit()。4fQ青帆网络
所以连字符在帝国 CMS 里根本不支持作为库名/表名,不止 ebak 一处会炸。4fQ青帆网络
所以数据库名 数据表名 都不要使用 - 连字符 全部使用_下划线 记住这是铁律